Troubleshooting Client Connector Install : SBS2011 Essentials

sbse-conThere are countless reports of problems installing the Client Connector on SBS Essentials and WHS. I’ll not mention WSSE as i don’t think anyone has even bought one yet Smile with tongue out

(that’s not true i do know people who have already deployed it)

Far more common at least, is for it to be an issue with SBSe or WHS2011.

I wanted to put together a resource for people who are struggling to get this installed, not built by me, but a collation of forum posts, solutions and tips that should either fix the issues, or point you in the right direction.

So first off, you might want to have a quick read through of this, which is my own post on how the process should work. It also gives some guidance on what to do if the profile move doesn’t work.

You may also be interested to know where the log files are for the Connector Install..

Windows XP

Log File Location, C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Server\Logs

This is a hidden folder.

Windows Vista / 7

Log file location, C:\ProgramData\Microsoft\Windows Server\Logs

This is a hidden folder

Did you know about the SBS 2011 Log Collector Tool?  You can read about that here

Troubleshooting the Installation

I thought it might be good to run through an install and try to monitor the logs and find out which log is most useful at which time.

The first log file, is Computerconnector.log, this shows a very high level progress indicator of the first steps of the install.

1

If you are a bit sad like me, and you do monitor the logs folder during a connector install, you will see the second log file to be generated is CSetup.log, which gives us a more detailed view of the early setup stages, for example when .NET 4 is installed.

csetup.log

You can also see that the CSetup.log file is 10kb, as opposed to Computerconnector.log 3kb.

3

When we get to the stage where you are prompted to enter your network username and password, we have a third log file. ClientDeploy.log, 

This log file picks up from CSetup.log

4

You can follow the progress of the next stage of deployment through this log file. You can see things like the tasks to locate the SBS Server, configuration of the local NIC DNS settings, and you can also spot errors and problems.

For example…

6

The log shows it has found a duplicate machine name, so it pauses the Join Domain task, to give you a chance, in the GUI to confirm you want to continue

5

And now i have hit a problem.

7

8

What you can see from the log here is that there is an Access Denied condition when trying to join the domain.

Why would that be?

In this instance, as mentioned above, a machine already existed in the domain with this name. Therefore, to join this current machine with the same name, i would need certain Active Directory (AD) permissions, which a normal network user account doesn’t have.

So how come a normal user can add a computer to the domain usually?

Whilst i don’t have the full technical answer to that question, i imagine it is something to do with certain settings have been set so that ANY account has the right to join a computer to the domain, but only the Domain Admin has the permissions to reset a machine account password, remove a machine from the domain, or overwrite a machine account in AD.

So, the solution here to get a clean join, would be to ensure any duplicate machine names have been removed from the server, either by the dashboard or through AD directly. Or simply rename the computer.

That being said, you can work around this issue by installing the connector using the Domain Admin credentials, and that will work in this situation, but doing so has it’s own caveats described here.

You might say, well i haven’t had a complete install on this PC yet so how can it possibly have a duplicate name.

To that i would say – maybe the first time you tried it, it failed on a different error? You fixed that and now attempt it again, but didn’t know to remove the account from the dashboard?

On this client, i removed the computer from the Dashboard, and re ran the connect software, using the same, NON ADMIN credentials.

In this screen shot i highlighted in Blue, where we started in the last screen shot ‘Calling Join Domain’ and ended in Red on the ‘JoinNetwork Tasks Task Status’ in Red.

9

The GUI of the wizard now shows us we need to reboot.

image

After the reboot, it is a little trickier to keep track of the logs because ‘Explorer.exe’ is not loaded up yet and we have no way to browse the logs folder.

11

So, if you want to, hit CTRL-ALT-DEL and go into task manager.

12

From task manager, click File, New Task, and then you can type in the folder path to the logs folder. (you may need to put it into quotes)

C:\Documents and Settings\All Users\Application Data\Microsoft\Windows Server\Logs

13

At this point we still have just our 3 log files.

Computerconnector.log

CSetup.log

ClientDeploy.log

Looking at ClientDeploy.log again, we can see in Red where we left off, and then where the process continued, and finally in Green the reboot.

15

Let’s move on through the GUI and see what happens to the logs. I am going to leave all of the options on their defaults.

We can see the profile is migrated.

16

In the GUI i am setting to wake the computer for backup and I am setting that i want to participate in the Customer Experience program.

When clicking next in the GUI on the Customer Experience program page, the GUI will display ‘Connecting this Computer to the network’ with a nice progress indicator.

17

At this point our ClientDeploy.log file is finished up, and we can now see a new Log File appears, ClientCoreX86.msi.log

After a few minutes, you will see a whole host of new log files appears.

18

With any luck in the GUI you will then see this..

19

I’m guessing you may not have done, which is why you are reading this… So let’s go and have a quick look through the ClientCoreX86.msi.log,

We now have 19 Log files by the way… and i am slowly starting to regret getting into this. Anyway..

20

We know that ClientDeploy.log finished, and ClientCoreX86.msi.log took over. That then spawned all of these other logs, but looking at the size of ClientDeploy.log i would say that also had some more info appended.

Switching to details view, we can see in what order these logs were written to.

21

In the first stages of ClientCoreX86.msi.log we can see that UR1 for SBS Essentials is referenced, and installed.

22

Moving on you can follow a huge amount of detail in this log – far too much for me to interpret or comment on, but this will be the place to look if you get errors in your install at this point.

You may notice a reference to the other Colorado products..

23a

(Cropped here to enlarge)

24

So NAS = Windows Storage Server 2008 R2… Nice.

You can follow the log file all the way though the installation of the Launchpad program and the setting up of things like allowing remote desktop to the machine. The other logs show the progress of individual tasks like adding of scheduled tasks or installing a backup driver. (not applicable on Windows XP)

When you have finished the installation, you will total 25 log files. The key ones for the installation have already been mentioned.

26

I hope that may of been some use to anyone struggling to find a reason why their connector may not install. If it doesn’t answer the question it may at least shed some light on where you can look for the answer. Of course failing that I have Susan Bradleys home address if you need it :p

Have a look at the links below if you need more specific help.

Client Connector Installation failures :  links to forums and known solutions

Please feel free to send me any solutions i don’t have, i want to have as many as possible!

These links, have been highlighted as answering the issues in the OP, i am not making any guarantee they will solve your issue, this is just somewhere to link them all together.

Microsoft’s Official Troubleshooting Resource For SBSE Connector

Microsoft Online Help

Pending File Rename

Susan Bradleys blog post

Trust Relationship (Time Zone Error / Certificate Policy)

TechNet forum post (Time Zone)

WeGotServed forum post

Microsoft Support KB Article 278381

TechNet forum post (Certificate Policy)

Username and Password Error

TechNet forum post (Username and Password)

Installation Cancelled

TechNet forum post (Installation Cancelled)

WeGotServed forum post

TitleRequired.com Quick Fix: Installation Cancelled

Cannot Find ‘Temp Client’

WeGotServed forum post

Task Scheduler

Susan Bradleys blog post

Wiki Links

Official SBS Wiki for Client Deployment

SBS MVPs wiki for Client Deployment

General Tips

Check the system time of both the server and the client. Check the Time Zone matches as well.

You shouldn’t need to use a static IP on the client machine, but it might help during troubleshooting.

Check for the overall health of your client PC. You don’t need a client to be fully patched, nor does it need the latest browser (examples above are all from IE6) but you do need a ‘healthy’ client. If you are having problems, take a backup, use tools like CCleaner, MalwareBytes, Look for issues on the client that stop it running normally rather than an issue with the Connector itself. A good example of that is from Eriq Neale, who had an issue with a machine installing the connector, which he traced back to a screwed up Task Manager.

Tips for a Migration

I have also seen some success on migrated computers, which are already in the domain but won’t install the connector, by creating a new local user, making that account a local admin, and then running the connect installer as that person.

Follow

Get every new post delivered to your Inbox.

Join 399 other followers

%d bloggers like this: